browser-sync


Error during instillation of browser sync


I had uninstalled browsersync and gulp which I installed globally (Due to issue: How to sync the actions performed on webpage using Browsersync?)
As below
> npm uninstall -g browser-sync
> npm uninstall -g gulp
I cross checked it as well as given below.
C:\Users\PPawar1\Desktop\BrowserSync\New Demo>browser-sync -version
'browser-sync' is not recognized as an internal or external command,
operable program or batch file.
C:\Users\PPawar1\Desktop\BrowserSync\New Demo>gulp -version
'gulp' is not recognized as an internal or external command,
operable program or batch file.
Now when I am trying to install it as given below, I am having this issue
C:\Users \Desktop\BrowserSync\New Demo>npm install browser-sync gulp --save-dev
Error:
npm WARN deprecated minimatch#2.0.10: Please update to minimatch 3.0.2 or higher
to avoid a RegExp DoS issue
npm WARN optional dep failed, continuing fsevents#1.0.14
npm WARN deprecated minimatch#0.2.14: Please update to minimatch 3.0.2 or higher
to avoid a RegExp DoS issue
npm WARN deprecated lodash#1.0.2: lodash#<3.0.0 is no longer maintained. Upgrade
to lodash#^4.0.0.
npm WARN deprecated tough-cookie#2.2.2: ReDoS vulnerability parsing Set-Cookie h
ttps://nodesecurity.io/advisories/130
npm WARN deprecated graceful-fs#1.2.3: graceful-fs v3.0.0 and before will fail o
n node releases >= v7.0. Please update to graceful-fs#^4.0.0 as soon as possible
. Use 'npm ls graceful-fs' to find it in the tree.
gulp#3.9.1 node_modules\gulp
├── interpret#1.0.1
├── pretty-hrtime#1.0.2
├── deprecated#0.0.1
├── archy#1.0.0
├── minimist#1.2.0
├── semver#4.3.6
├── tildify#1.2.0 (os-homedir#1.0.2)
├── v8flags#2.0.11 (user-home#1.1.1)
├── chalk#1.1.3 (supports-color#2.0.0, escape-string-regexp#1.0.5, ansi-styles#2
.2.1, has-ansi#2.0.0, strip-ansi#3.0.1)
├── orchestrator#0.3.7 (stream-consume#0.1.0, sequencify#0.0.7, end-of-stream#0.
1.5)
├── vinyl-fs#0.3.14 (graceful-fs#3.0.11, strip-bom#1.0.0, vinyl#0.4.6, mkdirp#0.
5.1, defaults#1.0.3, through2#0.6.5, glob-stream#3.1.18, glob-watcher#0.0.6)
├── liftoff#2.3.0 (lodash.isstring#4.0.1, lodash.isplainobject#4.0.6, lodash.map
values#4.6.0, rechoir#0.6.2, extend#3.0.0, flagged-respawn#0.3.2, resolve#1.1.7,
fined#1.0.2, findup-sync#0.4.3)
└── gulp-util#3.0.7 (array-differ#1.0.0, lodash._reescape#3.0.0, lodash._reinter
polate#3.0.0, beeper#1.1.0, array-uniq#1.0.3, lodash._reevaluate#3.0.0, object-a
ssign#3.0.0, replace-ext#0.0.1, has-gulplog#0.1.0, fancy-log#1.2.0, vinyl#0.5.3,
gulplog#1.0.0, lodash.template#3.6.2, through2#2.0.1, multipipe#0.1.2, dateform
at#1.0.12)
browser-sync#2.17.3 node_modules\browser-sync
├── emitter-steward#1.0.0
├── server-destroy#1.0.1
├── dev-ip#1.0.1
├── qs#6.2.1
├── immutable#3.8.1
├── ua-parser-js#0.7.10
├── browser-sync-client#2.4.2 (etag#1.7.0, fresh#0.3.0)
├── http-proxy#1.15.1 (eventemitter3#1.2.0, requires-port#1.0.0)
├── portscanner#1.0.0 (async#0.1.15)
├── opn#4.0.2 (object-assign#4.1.0, pinkie-promise#2.0.1)
├── resp-modifier#6.0.2 (debug#2.2.0, minimatch#3.0.3)
├── connect#3.5.0 (utils-merge#1.0.0, parseurl#1.3.1, debug#2.2.0, finalhandler#
0.5.0)
├── serve-static#1.11.1 (escape-html#1.0.3, encodeurl#1.0.1, parseurl#1.3.1, sen
d#0.14.1)
├── eazy-logger#3.0.2 (tfunk#3.0.2)
├── micromatch#2.3.11 (filename-regex#2.0.0, is-extglob#1.0.0, normalize-path#2.
0.1, is-glob#2.0.1, extglob#0.3.2, array-unique#0.2.1, expand-brackets#0.1.5, ki
nd-of#3.0.4, regex-cache#0.4.3, arr-diff#2.0.0, parse-glob#3.0.4, object.omit#2.
0.0, braces#1.8.5)
├── chokidar#1.6.0 (path-is-absolute#1.0.1, inherits#2.0.3, async-each#1.0.1, gl
ob-parent#2.0.0, is-glob#2.0.1, is-binary-path#1.0.1, anymatch#1.3.0, readdirp#2
.1.0)
├── fs-extra#0.30.0 (path-is-absolute#1.0.1, klaw#1.3.0, jsonfile#2.4.0, gracefu
l-fs#4.1.9, rimraf#2.5.4)
├── serve-index#1.8.0 (escape-html#1.0.3, parseurl#1.3.1, batch#0.5.3, http-erro
rs#1.5.0, mime-types#2.1.12, accepts#1.3.3, debug#2.2.0)
├── socket.io#1.5.0 (has-binary#0.1.7, debug#2.2.0, socket.io-parser#2.2.6, sock
et.io-adapter#0.4.0, engine.io#1.7.0, socket.io-client#1.5.0)
├── bs-recipes#1.2.3
├── yargs#6.0.0 (get-caller-file#1.0.2, decamelize#1.2.0, y18n#3.2.1, which-modu
le#1.0.0, set-blocking#2.0.0, require-main-filename#1.0.1, require-directory#2.1
.1, window-size#0.2.0, yargs-parser#4.0.2, cliui#3.2.0, string-width#1.0.2, os-l
ocale#1.4.0, read-pkg-up#1.0.1)
├── rx#4.1.0
├── easy-extender#2.3.2 (lodash#3.10.1)
├── localtunnel#1.8.1 (openurl#1.1.0, debug#2.2.0, yargs#3.29.0, request#2.65.0)
└── browser-sync-ui#0.6.1 (async-each-series#0.1.1, connect-history-api-fallback
#1.3.0, stream-throttle#0.1.3, weinre#2.0.0-pre-I0Z7U9OV)

Related Links

Make BrowserSync use the real https URL
Can we use browser sync on external url
How to replace .html with forward slash in BrowserSync?
Error during instillation of browser sync
When using browser-sync,why is the browser saying cannot get, while everything seems fine
How to sync the actions performed on webpage using Browsersync?
lite-server, BrowserSync: setting other URL path than /
Gulp and Browsersync injecting CSS but causing a full reload
Browser-sync - serve “node_modules” out of “src” directory
[browser-sync]browser-sync proxy can't connect to Rails Application
Browserstack not serving index.html by default
whatever i do i can't access the external URL for the site or UI
How do I kill browserSync before creating it?
Unable to install browser-sync on windows 7
browser-sync proxy fails to connect
What's the equivalent bs-config.js (Browsersync) of this command?

Categories

HOME
adal
cobalt
design-patterns
paraview
checkstyle
time-complexity
css3
gpu
angular-formly
powerpoint
swt
mysql-workbench
package
jsf-2.2
big-o
visual-studio-emulator
jquery-ui
pcl-crypto
dkim
distribution
appcelerator-studio
mod-security
cmdb
renjin
cumulocity
searchview
feathersjs
cfml
dpdk
dataflow-diagram
postscript
highstock
strongname
kudu
utorrent
deltaspike
code-snippets
indy10
jwplayer6
release
urlsession
watchface
odoo-website
importerror
wc
rfc3339
facebook-social-plugins
monkey-testing
httrack
gitlist
facebook-pixel
vugen
posixct
compiler-design
oracleclient
excel-dna
css-transforms
d3-force-directed
cmp
cubism.js
meteor-packages
flex-monkey
iotivity
jodd
drawstring
tooleap
gcloud-ruby
kendo-upload
qbxml
qt5.2
microsoft-reporting
xvim
android-launcher
skspritenode
iiop
primitive-types
sonarqube-5.0
metatrader5
linkedin-jsapi
grails-plugin-rabbitmq
amslidemenu
drupal-nodes
http-patch
ie8-compatibility-mode
isqlquery
tlf
kogrid
merb
route-provider
diem
font-awesome-4.0.0
chart-director
http-status-code-410
alice
device-width
ilasm
entity-attribute-value
ikimagebrowserview
lr
uipagecontrol
nhprof
commerceserver2007
delimited-text
rowlex
blender-2.49
duplex
cfwindow
strtod
lalr
purepdf
online-storage

Resources

Mobile Apps Dev
Database Users
javascript
java
csharp
php
android
MS Developer
developer works
python
ios
c
html
jquery
RDBMS discuss
Cloud Virtualization
Database Dev&Adm
javascript
java
csharp
php
python
android
jquery
ruby
ios
html
Mobile App
Mobile App
Mobile App